Cloudflare Connectivity Issues

Incident Report for UK Servers Status

Monitoring

CloudFlare believe the issue to now be resolved : https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 15:24 GMT

Investigating

At 11:34 we became aware of ongoing issues affecting Cloudflare’s global network.
Customers with services provided from CloudFlare are likely impacted by this.
Please follow their status here for updates: https://www.cloudflarestatus.com/

There is no issue on, or within, our own network.
Posted Nov 18, 2025 - 11:47 GMT
This incident affects: Coventry - Continuity House (205/DC3), Coventry (DH1), Coventry (DH2), Telehouse East (THE), Telehouse North (THN), Telehouse West (THW), Pulsant 2 (MHD), and Equinix MA1 (MCR).