We are continuing to monitor for any further issues.
Posted Jul 24, 2026 - 21:12 BST
Update
Connectivity should be restored for all customers at present. If you have any issues with a service remaining offline, please open a support ticket. We are continuing to monitor and investigate the incident.
Posted Jul 24, 2026 - 05:46 BST
Update
Our engineers are currently carrying out an emergency reload of the router, the expected disruption of this is 10 minutes. Customers services have been diverted to an alternative gateway where possible.
Posted Jul 24, 2026 - 05:19 BST
Monitoring
Service has now been restored for customers at this site. However, due to ongoing router instability, customers should still consider their services to be at risk.
Posted Jul 24, 2026 - 04:40 BST
Investigating
We are currently investigating a severe network issue affecting the router mx1.thw120
Our network engineers are diagnosing the problem and further updates should follow.
Dedicated or shared colocation customers within London datacentres may experience packet loss, increased latency or interruptions in connection whilst this is being resolved.
Posted Jul 24, 2026 - 04:31 BST
This incident affected: Telehouse East (THE), Telehouse North (THN), and Telehouse West (THW).