Network Incident - Coventry Datacentre

Incident Report for UK Servers Status

Update

Service has now been fully restored to all customers at our Coventry datacentre, a full RFO will be issued to all customers shortly.
Posted Jul 08, 2026 - 06:06 BST

Investigating

We are currently investigating a severe network issue affecting a router at our Coventry datacentre providing service to a number of customers from this site.

Our network engineers are diagnosing the problem and further updates should follow.

Dedicated or shared colocation customers may experience packet loss, increased latency or interruptions in connection whilst this is being resolved.
Posted Jul 08, 2026 - 05:54 BST
This incident affects: Coventry - Continuity House (205/DC3).