Coventry Network Issue

Incident Report for UK Servers Status

Update

We have identified the cause as the same hardware fault previously experienced on this router.
Following the earlier incident, we applied the remediation advised by Juniper, but as the fault has now recurred we no longer consider that remediation sufficient and will be replacing the affected device.
A maintenance window will be issued in the near future.
Posted Aug 24, 2026 - 07:57 BST

Monitoring

Service has been restored, we are continuing to investigate.
No further downtime is expected at this present time.
Posted Aug 24, 2026 - 06:51 BST

Investigating

We are investigating a network issue affecting one of our routers in Coventry.

We will provide further updates shortly.
Posted Aug 24, 2026 - 06:31 BST
This incident affects: Coventry - Continuity House (205/DC3).