The cause of this has been identified and a fix is being implemented.
A reminder that some customers may have mistakenly received a monitoring alert email despite not having a monitoring product. Only customers with an active management plan benefit from proactive monitoring. Regardless, the health of server storage drives and RAID arrays remains the customer’s responsibility to monitor unless explicitly agreed otherwise.
Posted Mar 23, 2026 - 14:20 GMT
Investigating
We are aware of automated emails sent to some customers reporting RAID degradation. These alerts were generated in error, and it is affecting customers across all management tiers including Foundation. We are looking into this and will get update the page shortly.
Posted Mar 23, 2026 - 08:02 GMT
This incident affects: Coventry - Continuity House (205/DC3), Coventry (DH1), Coventry (DH2), Telehouse East (THE), Telehouse North (THN), Telehouse West (THW), and Equinix MA1 (MCR).