Control Panel Unavailability
Incident Report for UK Servers Status
Resolved
The control panel is back up and running. No further interruption is expected
Posted Oct 23, 2023 - 13:07 BST
Identified
The customer control panel (https://control.ukservers.com) is currently experiencing an issue. This is being worked on, and we will hope to have the control panel back up as soon as possible.

In the meantime, all support enquiries can be directed to support@ukservers.com where they will be dealt with.

Apologies for the inconvenience.
Posted Oct 23, 2023 - 12:56 BST