The circuit remains down due to failed repair attempts on previous permitted maintenance windows from Network Rail. We will provide a further update when we receive one from the connectivity provider.
To reiterate the current impact of this incident to UKServers customers is: slightly higher latency for traffic that would otherwise usually ingress/egress though Manchester - as peering in the Manchester PoP is shutdown as a precaution.
Posted Nov 24, 2025 - 10:14 GMT
Update
Unfortunately the repairs proved unsuccessful. The connectivity provider will carry out their alternative repair plan, however this relies on permitted access from Network Rail and is scheduled for 00:01 - 07:59 on 23rd November UTC.
Posted Nov 22, 2025 - 21:08 GMT
Update
The latest update from the connectivity provider is that their fibre team are presently carrying out repairs and service should be restored within the next few hours.
Posted Nov 22, 2025 - 01:20 GMT
Update
The latest update from the connectivity provider is that their fibre team are presently carrying out repairs.
Posted Nov 21, 2025 - 19:41 GMT
Update
The connectivity provider has confirmed a fibre break and have dispatched repair teams. No ETA at this time but resolution expected within the next few hours.
Posted Nov 21, 2025 - 16:38 GMT
Identified
The connectivity provider has "identified Transport services impacted in Birmingham, United Kingdom" and expect to provide a further update within the next 2 hours.
Posted Nov 21, 2025 - 14:10 GMT
Investigating
One of our core connectivity wavelengths to Manchester is unexpectedly down.
Customers with services directly in Manchester should be considered at risk at present.
We have engaged the third-party connectivity partner and will provide further updates when we receive further information from them.